Mooven - UK customers unable to receive SMS messages including 2FA codes – Incident details

UK customers unable to receive SMS messages including 2FA codes

Resolved
Operational
Started over 1 year agoLasted 15 days

Affected

SMS Alerts

Updates
  • Resolved
    Resolved

    UK customers can now receive all types of SMS messages from us

  • Investigating
    Investigating

    We are investigating a period when we were unable to send SMS messages to users with UK (+44) mobile numbers. This will impact receiving both KPI breach SMS notifications and 2FA SMS codes.